Queries
id
ID of the object.
Тип: ID!
relay
Workaround for re-exposing the root query object. (Refer to https://github.com/facebook/relay/issues/112 for more information.).
Тип: Query!
Objects
CodeCoverageParameters
Enforce minimum line coverage thresholds on pull requests. This rule evaluates uploaded coverage data but does not wait for coverage uploads. To ensure coverage is evaluated before merging, make each status check associated with a coverage upload a required status check.
Поля для CodeCoverageParameters
| Имя. | Description |
|---|---|
| The maximum percentage points that line coverage may drop relative to the default branch. Pull requests that reduce line coverage by more than this amount will be blocked. |
| The absolute minimum line coverage percentage required. Pull requests with line coverage below this threshold will be blocked. |
PageInfo
Information about pagination in a connection.
Поля для PageInfo
| Имя. | Description |
|---|---|
| When paginating forwards, the cursor to continue. |
| When paginating forwards, are there more items?. |
| When paginating backwards, are there more items?. |
| When paginating backwards, the cursor to continue. |
Scalars
Base64String
A (potentially binary) string encoded using base64.
BigInt
Represents non-fractional signed whole numeric values. Since the value may exceed the size of a 32-bit integer, it's encoded as a string.
Boolean
Represents true or false values.
CustomPropertyValue
A custom property value can be either a string or an array of strings. All property types support only a single string value, except for the multi-select type, which supports only a string array.
Date
An ISO-8601 encoded date string.
DateTime
An ISO-8601 encoded UTC date string.
Float
Represents signed double-precision fractional values as specified by IEEE 754.
GitObjectID
A Git object ID.
GitRefname
A fully qualified reference name (e.g. refs/heads/master).
GitSSHRemote
Git SSH string.
GitTimestamp
An ISO-8601 encoded date string. Unlike the DateTime type, GitTimestamp is not converted in UTC.
HTML
A string containing HTML code.
ID
Represents a unique identifier that is Base64 obfuscated. It is often used to refetch an object or as key for a cache. The ID type appears in a JSON response as a String; however, it is not intended to be human-readable. When expected as an input type, any string (such as "VXNlci0xMA==") or integer (such as 4) input value will be accepted as an ID.
Int
Represents non-fractional signed whole numeric values. Int can represent values between -(2^31) and 2^31 - 1.
PreciseDateTime
An ISO-8601 encoded UTC date string with millisecond precision.
String
Represents textual data as UTF-8 character sequences. This type is most often used by GraphQL to represent free-form human-readable text.
URI
An RFC 3986, RFC 3987, and RFC 6570 (level 4) compliant URI string.
X509Certificate
A valid x509 certificate string.